[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2007-2666

Date: (C)2007-05-14   (M)2017-10-12
 
CVSS Score: 7.6Access Vector: NETWORK
Exploitability Subscore: 4.9Access Complexity: HIGH
Impact Subscore: 10.0Authentication: NONE
 Confidentiality: COMPLETE
 Integrity: COMPLETE
 Availability: COMPLETE











Stack-based buffer overflow in LexRuby.cxx (SciLexer.dll) in Scintilla 1.73, as used by notepad++ 4.1.1 and earlier, allows user-assisted remote attackers to execute arbitrary code via certain Ruby (.rb) files with long lines. NOTE: this was originally reported as a vulnerability in notepad++.

Reference:
http://www.securityfocus.com/archive/1/archive/1/468529/100/0/threaded
http://www.securityfocus.com/archive/1/archive/1/469348/100/100/threaded
BID-23961
SECUNIA-25245
SECUNIA-25327
OSVDB-36007
EXPLOIT-DB-3912
ADV-2007-1794
ADV-2007-1867
http://scintilla.cvs.sourceforge.net/scintilla/scintilla/src/LexRuby.cxx?view=log#rev1.13
notepadplus-rb-bo(34269)
scintilla-rb-bo(34372)

CWE    1
CWE-119

© 2013 SecPod Technologies