[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96125

 
 

909

 
 

78020

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2007-4137

Date: (C)2007-09-18   (M)2017-10-04
 
CVSS Score: 7.5Access Vector: NETWORK
Exploitability Subscore: 10.0Access Complexity: LOW
Impact Subscore: 6.4Authentication: NONE
 Confidentiality: PARTIAL
 Integrity: PARTIAL
 Availability: PARTIAL











Off-by-one error in the QUtf8Decoder::toUnicode function in Trolltech Qt 3 allows context-dependent attackers to cause a denial of service (crash) via a crafted Unicode string that triggers a heap-based buffer overflow. NOTE: Qt 4 has the same error in the QUtf8Codec::convertToUnicode function, but it is not exploitable.

Reference:
SECTRACK-1018688
20070901-01-P
http://www.securityfocus.com/archive/1/archive/1/481498/100/0/threaded
BID-25657
SECUNIA-26778
SECUNIA-26782
SECUNIA-26804
SECUNIA-26811
SECUNIA-26857
SECUNIA-26868
SECUNIA-26882
SECUNIA-26987
SECUNIA-27053
SECUNIA-27275
SECUNIA-27382
SECUNIA-27996
SECUNIA-28021
OSVDB-39384
ADV-2007-3144
DSA-1426
FEDORA-2007-2216
FEDORA-2007-703
GLSA-200710-28
GLSA-200712-08
MDKSA-2007:183
RHSA-2007:0883
SUSE-SR:2007:019
USN-513-1
http://bugs.gentoo.org/show_bug.cgi?id=192472
http://dist.trolltech.com/developer/download/175791_3.diff
http://dist.trolltech.com/developer/download/175791_4.diff
http://support.avaya.com/elmodocs2/security/ASA-2007-424.htm
http://trolltech.com/company/newsroom/announcements/press.2007-09-03.7564032119
https://bugzilla.redhat.com/show_bug.cgi?id=269001
https://issues.rpath.com/browse/RPL-1751

CWE    1
CWE-119

© 2013 SecPod Technologies