[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2007-4727

Date: (C)2007-09-12   (M)2017-07-31
 
CVSS Score: 6.8Access Vector: NETWORK
Exploitability Subscore: 8.6Access Complexity: MEDIUM
Impact Subscore: 6.4Authentication: NONE
 Confidentiality: PARTIAL
 Integrity: PARTIAL
 Availability: PARTIAL











Buffer overflow in the fcgi_env_add function in mod_proxy_backend_fastcgi.c in the mod_fastcgi extension in lighttpd before 1.4.18 allows remote attackers to overwrite arbitrary CGI variables and execute arbitrary code via an HTTP request with a long content length, as demonstrated by overwriting the SCRIPT_FILENAME variable, aka a "header overflow."

Reference:
http://www.securityfocus.com/archive/1/archive/1/479763/100/0/threaded
BID-25622
SECUNIA-26732
SECUNIA-26794
SECUNIA-26824
SECUNIA-26997
SECUNIA-27229
SREASON-3127
ADV-2007-3110
FEDORA-2007-2132
GLSA-200709-16
SUSE-SR:2007:020
http://secweb.se/en/advisories/lighttpd-fastcgi-remote-vulnerability/
http://trac.lighttpd.net/trac/changeset/1986
http://www.lighttpd.net/assets/2007/9/9/lighttpd_sa_2007_12.txt
https://bugzilla.redhat.com/show_bug.cgi?id=284511
https://issues.rpath.com/browse/RPL-1715
lighttpd-modfastcgi-code-execution(36526)

CPE    1
cpe:/a:lighttpd:lighttpd:1.4.15
CWE    1
CWE-119

© 2013 SecPod Technologies