[Forgot Password]
Login  Register Subscribe

23631

 
 

122183

 
 

98060

 
 

909

 
 

79198

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2007-5358

Date: (C)2007-10-12   (M)2017-07-31 


Multiple buffer overflows in the voicemail functionality in Asterisk 1.4.x before 1.4.13, when using IMAP storage, might allow (1) remote attackers to execute arbitrary code via a long combination of Content-type and Content-description headers, or (2) local users to execute arbitrary code via a long combination of astspooldir, voicemail context, and voicemail mailbox fields. NOTE: vector 2 requires write access to Asterisk configuration files.

CVSS Score: 6.8Access Vector: NETWORK
Exploit Score: 8.6Access Complexity: MEDIUM
Impact Score: 6.4Authentication: NONE
 Confidentiality: PARTIAL
 Integrity: PARTIAL
 Availability: PARTIAL





Reference:
SECTRACK-1018804
http://www.securityfocus.com/archive/1/archive/1/481996/100/0/threaded
BID-26005
SECUNIA-27184
OSVDB-38201
OSVDB-38202
ADV-2007-3454
asterisk-contentheader-bo(37052)
asterisk-sprintf-bo(37051)
http://downloads.digium.com/pub/security/AST-2007-022.html

CPE    1
cpe:/a:digium:asterisk:1.4.12
CWE    1
CWE-119

© 2013 SecPod Technologies