[Forgot Password]
Login  Register Subscribe

24128

 
 

131615

 
 

112965

 
 

909

 
 

87888

 
 

136

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML view JSON

CVE-2008-1384Date: (C)2008-03-27   (M)2018-06-01


Integer overflow in PHP 5.2.5 and earlier allows context-dependent attackers to cause a denial of service and possibly have unspecified other impact via a printf format parameter with a large width specifier, related to the php_sprintf_appendstring function in formatted_print.c and probably other functions for formatted strings (aka *printf functions).

CVSS Score and Metrics +CVSS Score and Metrics -

CVSS V2 Severity:
CVSS Score : 5.0
Exploit Score: 10.0
Impact Score: 2.9
 
CVSS V2 Metrics:
Access Vector: NETWORK
Access Complexity: LOW
Authentication: NONE
Confidentiality: NONE
Integrity: NONE
Availability: PARTIAL
  
Reference:
http://securityreason.com/achievement_securityalert/52
http://www.securityfocus.com/archive/1/archive/1/489962/100/0/threaded
http://www.securityfocus.com/archive/1/archive/1/492535/100/0/threaded
http://www.securityfocus.com/archive/1/archive/1/492671/100/0/threaded
BID-28392
SECUNIA-30158
SECUNIA-30345
SECUNIA-30411
SECUNIA-30967
SECUNIA-31200
SECUNIA-32746
DSA-1572
GLSA-200811-05
MDVSA-2009:022
MDVSA-2009:023
SUSE-SR:2008:014
USN-628-1
http://cvs.php.net/viewvc.cgi/php-src/NEWS?revision=1.2027.2.547.2.1120&view=markup
http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0176
http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0178
https://issues.rpath.com/browse/RPL-2503
php-phpsprintfappendstring-overflow(41386)

CPE    1
cpe:/a:php:php:5.2.5
CWE    1
CWE-189
OVAL    2
oval:org.mitre.oval:def:7889
oval:org.secpod.oval:def:300482

© SecPod Technologies