[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2008-2358

Date: (C)2008-06-09   (M)2017-10-04
 
CVSS Score: 7.2Access Vector: LOCAL
Exploitability Subscore: 3.9Access Complexity: LOW
Impact Subscore: 10.0Authentication: NONE
 Confidentiality: COMPLETE
 Integrity: COMPLETE
 Availability: COMPLETE











Integer overflow in the dccp_feat_change function in net/dccp/feat.c in the Datagram Congestion Control Protocol (DCCP) subsystem in the Linux kernel 2.6.18, and 2.6.17 through 2.6.20, allows local users to gain privileges via an invalid feature length, which leads to a heap-based buffer overflow.

Reference:
SECTRACK-1020211
BID-29603
SECUNIA-30000
SECUNIA-30818
SECUNIA-30849
SECUNIA-30920
SECUNIA-31107
DSA-1592
FEDORA-2008-5893
MDVSA-2008:112
MDVSA-2008:167
RHSA-2008:0519
SUSE-SA:2008:030
USN-625-1
https://bugzilla.redhat.com/show_bug.cgi?id=447389
linux-kernel-dccpfeatchange-bo(43034)

CPE    4
cpe:/o:linux:linux_kernel:2.6.17
cpe:/o:linux:linux_kernel:2.6.19
cpe:/o:linux:linux_kernel:2.6.18
cpe:/o:linux:linux_kernel:2.6.20
...
CWE    1
CWE-189
OVAL    3
oval:org.secpod.oval:def:301393
oval:org.secpod.oval:def:301293
oval:org.mitre.oval:def:8118

© 2013 SecPod Technologies