[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2008-2376

Date: (C)2008-07-08   (M)2017-10-04
 
CVSS Score: 7.5Access Vector: NETWORK
Exploitability Subscore: 10.0Access Complexity: LOW
Impact Subscore: 6.4Authentication: NONE
 Confidentiality: PARTIAL
 Integrity: PARTIAL
 Availability: PARTIAL











Integer overflow in the rb_ary_fill function in array.c in Ruby before revision 17756 allows context-dependent attackers to cause a denial of service (crash) or possibly have unspecified other impact via a call to the Array#fill method with a start (aka beg) argument greater than ARY_MAX_SIZE. NOTE: this issue exists because of an incomplete fix for other closely related integer overflows.

Reference:
http://www.securityfocus.com/archive/1/archive/1/494104/100/0/threaded
SECUNIA-30927
SECUNIA-31006
SECUNIA-31062
SECUNIA-31090
SECUNIA-31181
SECUNIA-31256
SECUNIA-32219
SECUNIA-33178
ADV-2008-2584
APPLE-SA-2008-09-15
DSA-1612
DSA-1618
FEDORA-2008-6094
GLSA-200812-17
MDVSA-2008:140
MDVSA-2008:141
MDVSA-2008:142
RHSA-2008:0561
TA08-260A
USN-651-1
http://www.openwall.com/lists/oss-security/2008/07/02/3
http://wiki.rpath.com/Advisories:rPSA-2008-0218
http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0218
https://issues.rpath.com/browse/RPL-2639

CWE    1
CWE-189
OVAL    4
oval:org.secpod.oval:def:301570
oval:org.secpod.oval:def:301246
oval:org.mitre.oval:def:7871
oval:org.mitre.oval:def:7922
...

© 2013 SecPod Technologies