[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2008-2829

Date: (C)2008-06-23   (M)2017-08-08
 
CVSS Score: 5.0Access Vector: NETWORK
Exploitability Subscore: 10.0Access Complexity: LOW
Impact Subscore: 2.9Authentication: NONE
 Confidentiality: NONE
 Integrity: NONE
 Availability: PARTIAL











php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long IMAP request, which triggers an "rfc822.c legacy routine buffer overflow" error message, related to the rfc822_write_address function.

Reference:
http://www.securityfocus.com/archive/1/archive/1/501376/100/0/threaded
BID-29829
SECUNIA-31200
SECUNIA-32746
SECUNIA-35074
SECUNIA-35306
SECUNIA-35650
OSVDB-46641
ADV-2009-1297
APPLE-SA-2009-05-12
FEDORA-2009-3768
FEDORA-2009-3848
GLSA-200811-05
HPSBUX02431
HPSBUX02465
MDVSA-2008:126
MDVSA-2008:127
MDVSA-2008:128
SSRT090085
SSRT090192
SUSE-SR:2008:027
TA09-133A
USN-628-1
http://www.openwall.com/lists/oss-security/2008/06/19/6
http://www.openwall.com/lists/oss-security/2008/06/24/2
http://bugs.php.net/bug.php?id=42862
http://support.apple.com/kb/HT3549
http://wiki.rpath.com/Advisories:rPSA-2009-0035
https://bugs.gentoo.org/show_bug.cgi?id=221969
php-phpimap-dos(43357)

CPE    3
cpe:/a:php:php:5.2.5
cpe:/a:php:php:5.2.6
cpe:/a:php:php:4.0
CWE    1
CWE-119
OVAL    7
oval:org.secpod.oval:def:301530
oval:org.secpod.oval:def:301251
oval:org.secpod.oval:def:301343
oval:org.secpod.oval:def:101758
...

© 2013 SecPod Technologies