[Forgot Password]
Login  Register Subscribe

23631

 
 

127000

 
 

102010

 
 

909

 
 

81309

 
 

123

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML view JSON

CVE-2008-3657Date: (C)2008-08-12   (M)2018-02-19


The dl module in Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not check "taintness" of inputs, which allows context-dependent attackers to bypass safe levels and execute dangerous functions by accessing a library using DL.dlopen.

CVSS V3 Severity:CVSS V2 Severity:
CVSS Score  : CVSS Score  : 7.5
Exploit Score: Exploit Score: 10.0
Impact Score : Impact Score : 6.4
 
CVSS V3 Metrics:CVSS V2 Metrics:
Attack Vector: Access Vector: NETWORK
Attack Complexity: Access Complexity: LOW
Privileges Required: Authentication: NONE
User Interaction: Confidentiality: PARTIAL
Scope: Integrity: PARTIAL
Confidentiality: Availability: PARTIAL
Integrity:  
Availability:  
  





Reference:
SECTRACK-1020652
http://www.securityfocus.com/archive/1/archive/1/495884/100/0/threaded
BID-30644
SECUNIA-31430
SECUNIA-31697
SECUNIA-32165
SECUNIA-32219
SECUNIA-32255
SECUNIA-32256
SECUNIA-32371
SECUNIA-33178
SECUNIA-35074
ADV-2008-2334
ADV-2009-1297
APPLE-SA-2009-05-12
DSA-1651
DSA-1652
FEDORA-2008-8736
FEDORA-2008-8738
GLSA-200812-17
RHSA-2008:0897
TA09-133A
USN-651-1
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=494401
http://support.apple.com/kb/HT3549
http://support.avaya.com/elmodocs2/security/ASA-2008-424.htm
http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0264
http://www.ruby-lang.org/en/news/2008/08/08/multiple-vulnerabilities-in-ruby/
ruby-dl-security-bypass(44372)

CPE    8
cpe:/a:ruby-lang:ruby:1.8.7:p22
cpe:/a:ruby-lang:ruby:1.8.7:preview2
cpe:/a:ruby-lang:ruby:1.8.7:preview1
cpe:/a:ruby-lang:ruby:1.8.7:preview4
...
CWE    1
CWE-20
OVAL    4
oval:org.secpod.oval:def:301443
oval:org.secpod.oval:def:400065
oval:org.mitre.oval:def:7935
oval:org.mitre.oval:def:8055
...

© 2013 SecPod Technologies