[Forgot Password]
Login  Register Subscribe

23631

 
 

122183

 
 

98060

 
 

909

 
 

79198

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2008-4555

Date: (C)2008-10-14   (M)2017-08-08 


Stack-based buffer overflow in the push_subg function in parser.y (lib/graph/parser.c) in Graphviz 2.20.2, and possibly earlier versions, allows user-assisted remote attackers to cause a denial of service (memory corruption) or execute arbitrary code via a DOT file with a large number of Agraph_t elements.

CVSS Score: 8.5Access Vector: NETWORK
Exploit Score: 6.8Access Complexity: MEDIUM
Impact Score: 10.0Authentication: SINGLE_INSTANCE
 Confidentiality: COMPLETE
 Integrity: COMPLETE
 Availability: COMPLETE





Reference:
http://www.securityfocus.com/archive/1/archive/1/497150/100/0/threaded
BID-31648
SECUNIA-32186
SECUNIA-32656
SREASON-4409
GLSA-200811-04
SUSE-SR:2008:023
graphviz-pushsubg-bo(45765)
http://bugs.gentoo.org/show_bug.cgi?id=240636
http://roeehay.blogspot.com/2008/10/graphviz-buffer-overflow-code-execution.html

CWE    1
CWE-119
OVAL    2
oval:org.secpod.oval:def:300809
oval:org.secpod.oval:def:300900

© 2013 SecPod Technologies