[Forgot Password]
Login  Register Subscribe

23631

 
 

126941

 
 

98250

 
 

909

 
 

79281

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2009-0388

Date: (C)2009-02-04   (M)2017-10-04 


Multiple integer signedness errors in (1) UltraVNC 1.0.2 and 1.0.5 and (2) TightVnc 1.3.9 allow remote VNC servers to cause a denial of service (heap corruption and application crash) or possibly execute arbitrary code via a large length value in a message, related to the (a) ClientConnection::CheckBufferSize and (b) ClientConnection::CheckFileZipBufferSize functions in ClientConnection.cpp.

CVSS Score: 10.0Access Vector: NETWORK
Exploit Score: 10.0Access Complexity: LOW
Impact Score: 10.0Authentication: NONE
 Confidentiality: COMPLETE
 Integrity: COMPLETE
 Availability: COMPLETE





Reference:
http://www.securityfocus.com/archive/1/archive/1/500632/100/0/threaded
BID-33568
SECUNIA-33807
EXPLOIT-DB-7990
EXPLOIT-DB-8024
ADV-2009-0321
ADV-2009-0322
http://forum.ultravnc.info/viewtopic.php?t=14654
http://vnc-tight.svn.sourceforge.net/viewvc/vnc-tight?view=rev&revision=3564
http://www.coresecurity.com/content/vnc-integer-overflows

CPE    1
cpe:/a:tightvnc:tightvnc:1.3.9
CWE    1
CWE-189

© 2013 SecPod Technologies