[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2009-0490

Date: (C)2009-02-09   (M)2017-10-04
 
CVSS Score: 9.3Access Vector: NETWORK
Exploitability Subscore: 8.6Access Complexity: MEDIUM
Impact Subscore: 10.0Authentication: NONE
 Confidentiality: COMPLETE
 Integrity: COMPLETE
 Availability: COMPLETE











Stack-based buffer overflow in the String_parse::get_nonspace_quoted function in lib-src/allegro/strparse.cpp in Audacity 1.2.6 and other versions before 1.3.6 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a .gro file containing a long string.

Reference:
BID-33090
SECUNIA-33356
OSVDB-51070
EXPLOIT-DB-7634
ADV-2009-0008
SUSE-SR:2009:004
http://n2.nabble.com/Audacity-%22String_parse::get_nonspace_quoted%28%29%22-Buffer-Overflow-td2139537.html
http://bugs.gentoo.org/show_bug.cgi?id=253493

CPE    1
cpe:/a:audacity:audacity:1.2.6
CWE    1
CWE-119
OVAL    1
oval:org.secpod.oval:def:300797

© 2013 SecPod Technologies