[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2009-1914

Date: (C)2009-06-04   (M)2017-08-18
 
CVSS Score: 4.9Access Vector: LOCAL
Exploitability Subscore: 3.9Access Complexity: LOW
Impact Subscore: 6.9Authentication: NONE
 Confidentiality: NONE
 Integrity: NONE
 Availability: COMPLETE











The pci_register_iommu_region function in arch/sparc/kernel/pci_common.c in the Linux kernel before 2.6.29 on the sparc64 platform allows local users to cause a denial of service (system crash) by reading the /proc/iomem file, related to uninitialized pointers and the request_resource function.

Reference:
BID-35415
SECUNIA-35656
SECUNIA-36051
OSVDB-54908
DSA-1844
USN-793-1
http://www.openwall.com/lists/oss-security/2009/06/03/3
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=192d7a4667c6d11d1a174ec4cad9a3c5d5f9043c
http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.29
kernel-pciregister-dos(51196)

CPE    291
cpe:/o:linux:linux_kernel:2.6.20.19
cpe:/o:linux:linux_kernel:2.6.23.1
cpe:/o:linux:linux_kernel:2.6.23.2
cpe:/o:linux:linux_kernel:2.6.23.3
...
CWE    1
CWE-20
OVAL    3
oval:org.secpod.oval:def:700305
oval:org.mitre.oval:def:8024
oval:org.secpod.oval:def:600432

© 2013 SecPod Technologies