[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2009-1932

Date: (C)2009-06-04   (M)2017-10-04
 
CVSS Score: 6.8Access Vector: NETWORK
Exploitability Subscore: 8.6Access Complexity: MEDIUM
Impact Subscore: 6.4Authentication: NONE
 Confidentiality: PARTIAL
 Integrity: PARTIAL
 Availability: PARTIAL











Multiple integer overflows in the (1) user_info_callback, (2) user_endrow_callback, and (3) gst_pngdec_task functions (ext/libpng/gstpngdec.c) in GStreamer Good Plug-ins (aka gst-plugins-good or gstreamer-plugins-good) 0.10.15 allow remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted PNG file, which triggers a buffer overflow.

Reference:
BID-35172
SECUNIA-35205
SECUNIA-35583
SECUNIA-35777
SECUNIA-35897
OSVDB-54827
ADV-2009-1506
DSA-1839
GLSA-200907-11
MDVSA-2009:130
RHSA-2009:1123
http://cgit.freedesktop.org/gstreamer/gst-plugins-good/commit/?id=d9544bcc44adcef769cbdf7f6453e140058a3adc

CWE    1
CWE-189
OVAL    8
oval:org.mitre.oval:def:7454
oval:org.secpod.oval:def:202164
oval:org.secpod.oval:def:500541
oval:org.secpod.oval:def:300641
...

© 2013 SecPod Technologies