[Forgot Password]
Login  Register Subscribe

23631

 
 

117687

 
 

98503

 
 

909

 
 

79281

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2009-3546

Date: (C)2009-10-19   (M)2017-11-18 


The _gdGetColors function in gd_gd.c in PHP 5.2.11 and 5.3.x before 5.3.1, and the GD Graphics Library 2.x, does not properly verify a certain colorsTotal structure member, which might allow remote attackers to conduct buffer overflow or buffer over-read attacks via a crafted GD file, a different vulnerability than CVE-2009-3293. NOTE: some of these details are obtained from third party information.

CVSS Score: 9.3Access Vector: NETWORK
Exploit Score: 8.6Access Complexity: MEDIUM
Impact Score: 10.0Authentication: NONE
 Confidentiality: COMPLETE
 Integrity: COMPLETE
 Availability: COMPLETE





Reference:
BID-36712
SECUNIA-37069
SECUNIA-37080
SECUNIA-38055
ADV-2009-2929
ADV-2009-2930
MDVSA-2009:285
RHSA-2010:0003
http://marc.info/?l=oss-security&m=125562113503923&w=2
http://www.openwall.com/lists/oss-security/2009/11/20/5
http://svn.php.net/viewvc?view=revision&revision=289557

CPE    2
cpe:/a:php:php:5.3.0
cpe:/a:php:php:5.2.11
CWE    1
CWE-119
OVAL    26
oval:org.secpod.oval:def:103957
oval:org.secpod.oval:def:200019
oval:org.secpod.oval:def:201766
oval:org.secpod.oval:def:201725
...

© 2013 SecPod Technologies