[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

95906

 
 

909

 
 

77982

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2010-3444

Date: (C)2011-01-10   (M)2017-08-18
 
CVSS Score: 7.5Access Vector: NETWORK
Exploitability Subscore: 10.0Access Complexity: LOW
Impact Subscore: 6.4Authentication: NONE
 Confidentiality: PARTIAL
 Integrity: PARTIAL
 Availability: PARTIAL











Buffer overflow in the log2vis_utf8 function in pyfribidi.c in GNU FriBidi 0.19.1, 0.19.2, and possibly other versions, as used in PyFriBidi 0.10.1, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted Arabic UTF-8 string that causes original 2-byte UTF-8 sequences to be transformed into 3-byte sequences.

Reference:
SECUNIA-42868
BID-43592
ADV-2011-0058
FEDORA-2011-0001
FEDORA-2011-0010
fribidi-log2visutf8-bo(64619)
http://sourceforge.net/tracker/?func=detail&aid=2676136&group_id=158366&atid=807545
https://bugzilla.redhat.com/show_bug.cgi?id=565997

CWE    1
CWE-119
OVAL    2
oval:org.secpod.oval:def:101149
oval:org.secpod.oval:def:101175

© 2013 SecPod Technologies