[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2010-4171

Date: (C)2010-12-07   (M)2017-08-18
 
CVSS Score: 2.1Access Vector: LOCAL
Exploitability Subscore: 3.9Access Complexity: LOW
Impact Subscore: 2.9Authentication: NONE
 Confidentiality: NONE
 Integrity: NONE
 Availability: PARTIAL











The staprun runtime tool in SystemTap 1.3 does not verify that a module to unload was previously loaded by SystemTap, which allows local users to cause a denial of service (unloading of arbitrary kernel modules).

Reference:
SECTRACK-1024754
SECUNIA-42256
SECUNIA-42263
SECUNIA-42318
BID-44917
SECUNIA-46920
DSA-2348
FEDORA-2010-17865
FEDORA-2010-17868
FEDORA-2010-17873
RHSA-2010:0894
http://sources.redhat.com/ml/systemtap/2010-q4/msg00230.html
http://sources.redhat.com/git/gitweb.cgi?p=systemtap.git;a=commit;h=b7565b41228bea196cefa3a7d43ab67f8f9152e2
https://bugzilla.redhat.com/show_bug.cgi?id=653606
systemtap-staprunmod-dos(63345)

CPE    1
cpe:/a:systemtap:systemtap:1.3
CWE    1
CWE-20
OVAL    9
oval:org.secpod.oval:def:100349
oval:org.secpod.oval:def:100844
oval:org.secpod.oval:def:103152
oval:org.secpod.oval:def:600634
...

© 2013 SecPod Technologies