[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2011-0755

Date: (C)2011-02-02   (M)2017-09-22
 
CVSS Score: 5.0Access Vector: NETWORK
Exploitability Subscore: 10.0Access Complexity: LOW
Impact Subscore: 2.9Authentication: NONE
 Confidentiality: NONE
 Integrity: PARTIAL
 Availability: NONE











Integer overflow in the mt_rand function in PHP before 5.3.4 might make it easier for context-dependent attackers to predict the return values by leveraging a script's use of a large max parameter, as demonstrated by a value that exceeds mt_getrandmax.

Reference:
http://bugs.php.net/46587
http://www.php.net/ChangeLog-5.php
php-mtrand-weak-security(65426)

CPE    111
cpe:/a:php:php:5.2.11
cpe:/a:php:php:5.2.10
cpe:/a:php:php:5.3.2
cpe:/a:php:php:5.3.3
...
CWE    1
CWE-189
OVAL    1
oval:org.secpod.oval:def:76

© 2013 SecPod Technologies