[Forgot Password]
Login  Register Subscribe

24002

 
 

127027

 
 

102010

 
 

909

 
 

81374

 
 

133

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML view JSON

CVE-2011-2939Date: (C)2012-01-13   (M)2018-02-19


Off-by-one error in the decode_xs function in Unicode/Unicode.xs in the Encode module before 2.44, as used in Perl before 5.15.6, might allow context-dependent attackers to cause a denial of service (memory corruption) via a crafted Unicode string, which triggers a heap-based buffer overflow.

CVSS Score and Metrics +CVSS Score and Metrics -

CVSS V3 Severity:CVSS V2 Severity:
CVSS Score : CVSS Score : 5.1
Exploit Score: Exploit Score: 4.9
Impact Score: Impact Score: 6.4
 
CVSS V3 Metrics:CVSS V2 Metrics:
Attack Vector: Access Vector: NETWORK
Attack Complexity: Access Complexity: HIGH
Privileges Required: Authentication: NONE
User Interaction: Confidentiality: PARTIAL
Scope: Integrity: PARTIAL
Confidentiality: Availability: PARTIAL
Integrity:  
Availability:  
  
Reference:
SECUNIA-46172
SECUNIA-46989
BID-49858
SECUNIA-51457
MDVSA-2012:008
RHSA-2011:1424
USN-1643-1
http://www.openwall.com/lists/oss-security/2011/08/18/8
http://www.openwall.com/lists/oss-security/2011/08/19/17
http://cpansearch.perl.org/src/FLORA/perl-5.14.2/pod/perldelta.pod
http://perl5.git.perl.org/perl.git/commitdiff/e46d973584785af1f445c4dedbee4243419cb860#patch5
http://search.cpan.org/~flora/perl-5.14.2/pod/perldelta.pod#Encode_decode_xs_n-byte_heap-overflow_(CVE-2011-2939)
https://bugzilla.redhat.com/show_bug.cgi?id=731246

CPE    176
cpe:/a:dan_kogai:encode_module:1.60
cpe:/a:dan_kogai:encode_module:2.20
cpe:/a:dan_kogai:encode_module:1.51
cpe:/a:dan_kogai:encode_module:2.21
...
CWE    1
CWE-189
OVAL    3
oval:org.secpod.oval:def:302855
oval:org.secpod.oval:def:500250
oval:org.secpod.oval:def:701086

© 2013 SecPod Technologies