[Forgot Password]
Login  Register Subscribe

23631

 
 

126941

 
 

98250

 
 

909

 
 

79281

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2011-3149

Date: (C)2012-07-22   (M)2017-11-18 


The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).

CVSS Score: 2.1Access Vector: LOCAL
Exploit Score: 3.9Access Complexity: LOW
Impact Score: 2.9Authentication: NONE
 Confidentiality: NONE
 Integrity: NONE
 Availability: PARTIAL





Reference:
SECUNIA-46583
SECUNIA-49711
GLSA-201206-31
USN-1237-1
http://git.fedorahosted.org/git/?p=linux-pam.git;a=commitdiff;h=109823cb621c900c07c4b6cdc99070d354d19444
https://bugs.launchpad.net/ubuntu/+source/pam/+bug/874565

CPE    26
cpe:/a:kernel:linux-pam:0.99.7.0
cpe:/a:kernel:linux-pam:0.99.6.1
cpe:/a:kernel:linux-pam:0.99.6.0
cpe:/a:kernel:linux-pam:0.99.5.0
...
CWE    1
CWE-119
OVAL    6
oval:org.secpod.oval:def:400304
oval:org.secpod.oval:def:400312
oval:org.secpod.oval:def:1600264
oval:org.secpod.oval:def:500991
...

© 2013 SecPod Technologies