[Forgot Password]
Login  Register Subscribe

23631

 
 

122183

 
 

98060

 
 

909

 
 

79198

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2012-1176

Date: (C)2012-08-26   (M)2017-08-29 


Buffer overflow in the fribidi_utf8_to_unicode function in PyFriBidi before 0.11.0 allows remote attackers to cause a denial of service (application crash) via a 4-byte utf-8 sequence.

CVSS Score: 5.0Access Vector: NETWORK
Exploit Score: 10.0Access Complexity: LOW
Impact Score: 2.9Authentication: NONE
 Confidentiality: NONE
 Integrity: NONE
 Availability: PARTIAL





Reference:
BID-52451
FEDORA-2012-3513
FEDORA-2012-3537
FEDORA-2012-3549
http://www.openwall.com/lists/oss-security/2012/03/14/4
http://www.openwall.com/lists/oss-security/2012/03/14/9
fribidi-utf8-bo(74001)
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=663189
http://groups.google.com/group/linux.debian.bugs.dist/browse_thread/thread/aacd036037217998/8d095f85f3665bff?lnk=raot
https://bugzilla.redhat.com/show_bug.cgi?id=801896
https://bugzilla.wikimedia.org/show_bug.cgi?id=35055
https://github.com/pediapress/pyfribidi/commit/d2860c655357975e7b32d84e6b45e98f0dcecd7a
https://github.com/pediapress/pyfribidi/issues/2%29:

CWE    1
CWE-119

© 2013 SecPod Technologies