[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2012-3236

Date: (C)2012-07-12   (M)2017-08-29
 
CVSS Score: 4.3Access Vector: NETWORK
Exploitability Subscore: 8.6Access Complexity: MEDIUM
Impact Subscore: 2.9Authentication: NONE
 Confidentiality: NONE
 Integrity: NONE
 Availability: PARTIAL











fits-io.c in GIMP before 2.8.1 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a malformed XTENSION header of a .fit file, as demonstrated using a long string.

Reference:
EXPLOIT-DB-19482
http://archives.neohapsis.com/archives/bugtraq/2012-06/0192.html
BID-54246
MDVSA-2013:082
USN-1559-1
gimp-fit-dos(76658)
http://git.gnome.org/browse/gimp/commit/plug-ins/file-fits/fits-io.c?id=ace45631595e8781a1420842582d67160097163c
http://www.reactionpenetrationtesting.co.uk/FIT-file-handling-dos.html
https://bugzilla.gnome.org/show_bug.cgi?id=676804
openSUSE-SU-2012:1080

CPE    2
cpe:/a:gnu:gimp:2.6.11
cpe:/a:gnu:gimp:2.6.8
CWE    1
CWE-119
OVAL    2
oval:org.secpod.oval:def:400372
oval:org.secpod.oval:def:700992

© 2013 SecPod Technologies