[Forgot Password]
Login  Register Subscribe

24128

 
 

131573

 
 

110210

 
 

909

 
 

86021

 
 

136

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML view JSON

CVE-2015-5288Date: (C)2015-12-15   (M)2018-06-03


The crypt function in contrib/pgcrypto in PostgreSQL before 9.0.23, 9.1.x before 9.1.19, 9.2.x before 9.2.14, 9.3.x before 9.3.10, and 9.4.x before 9.4.5 allows attackers to cause a denial of service (server crash) or read arbitrary server memory via a "too-short" salt.

CVSS Score and Metrics +CVSS Score and Metrics -

CVSS V3 Severity:CVSS V2 Severity:
CVSS Score : CVSS Score : 6.4
Exploit Score: Exploit Score: 10.0
Impact Score: Impact Score: 4.9
 
CVSS V3 Metrics:CVSS V2 Metrics:
Attack Vector: Access Vector: NETWORK
Attack Complexity: Access Complexity: LOW
Privileges Required: Authentication: NONE
User Interaction: Confidentiality: PARTIAL
Scope: Integrity: NONE
Confidentiality: Availability: PARTIAL
Integrity:  
Availability:  
  
Reference:
SECTRACK-1033775
BID-77049
DSA-3374
DSA-3475
FEDORA-2015-6d2a957a87
FEDORA-2015-7
GLSA-201701-33
SUSE-SU-2016:0677
USN-2772-1
http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
http://www.postgresql.org/about/news/1615/
http://www.postgresql.org/docs/9.0/static/release-9-0-23.html
http://www.postgresql.org/docs/9.1/static/release-9-1-19.html
http://www.postgresql.org/docs/9.2/static/release-9-2-14.html
http://www.postgresql.org/docs/9.3/static/release-9-3-10.html
http://www.postgresql.org/docs/9.4/static/release-9-4-5.html
openSUSE-SU-2015:1907
openSUSE-SU-2015:1919

CPE    25
cpe:/a:postgresql:postgresql:9.1.7
cpe:/a:postgresql:postgresql:9.1.6
cpe:/a:postgresql:postgresql:9.1.5
cpe:/a:postgresql:postgresql:9.1.4
...
CWE    1
CWE-200
OVAL    14
oval:org.secpod.oval:def:702792
oval:org.secpod.oval:def:30208
oval:org.secpod.oval:def:602248
oval:org.secpod.oval:def:602370
...

© SecPod Technologies