[Forgot Password]
Login  Register Subscribe

23631

 
 

125371

 
 

98503

 
 

909

 
 

79321

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2016-1248

Date: (C)2016-11-25   (M)2017-12-01 


vim before patch 8.0.0056 does not properly validate values for the 'filetype', 'syntax' and 'keymap' options, which may result in the execution of arbitrary code if a file with a specially crafted modeline is opened.

CVSS Score: 6.8Access Vector: NETWORK
Exploit Score: 8.6Access Complexity: MEDIUM
Impact Score: 6.4Authentication: NONE
 Confidentiality: PARTIAL
 Integrity: PARTIAL
 Availability: PARTIAL





Reference:
SECTRACK-1037338
BID-94478
DSA-3722
GLSA-201701-29
RHSA-2016:2972
USN-3139-1
http://openwall.com/lists/oss-security/2016/11/22/20
https://anonscm.debian.org/cgit/pkg-vim/vim.git/tree/debian/changelog
https://github.com/neovim/neovim/commit/4fad66fbe637818b6b3d6bc5d21923ba72795040
https://github.com/vim/vim/commit/d0b5138ba4bccff8a744c99836041ef6322ed39a
https://github.com/vim/vim/releases/tag/v8.0.0056
https://lists.debian.org/debian-lts-announce/2016/11/msg00025.html
https://lists.debian.org/debian-security-announce/2016/msg00305.html
https://www.debian.org/security/2016/dsa-3722

CPE    1
cpe:/o:debian:debian_linux:8.0
CWE    1
CWE-20
OVAL    10
oval:org.secpod.oval:def:1501708
oval:org.secpod.oval:def:204062
oval:org.secpod.oval:def:1600486
oval:org.secpod.oval:def:204064
...

© 2013 SecPod Technologies