[Forgot Password]
Login  Register Subscribe

23631

 
 

115083

 
 

97147

 
 

909

 
 

78730

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

ELSA-2014-0626 -- Oracle openssl098e

ID: oval:org.secpod.oval:def:1500560Date: (C)2014-06-10   (M)2017-10-27
Class: PATCHFamily: unix




Updated openssl097a and openssl098e packages that fix one security issue are now available for Red Hat Enterprise Linux 5 and 6 respectively. The Red Hat Security Response Team has rated this update as having Important security impact. A Common Vulnerability Scoring System base score, which gives a detailed severity rating, is available from the CVE link in the References section. OpenSSL is a toolkit that implements the Secure Sockets Layer and Transport Layer Security protocols, as well as a full-strength, general purpose cryptography library. It was found that OpenSSL clients and servers could be forced, via a specially crafted handshake packet, to use weak keying material for communication. A man-in-the-middle attacker could use this flaw to decrypt and modify traffic between a client and a server. Note: In order to exploit this flaw, both the server and the client must be using a vulnerable version of OpenSSL; the server must be using OpenSSL version 1.0.1 and above, and the client must be using any version of OpenSSL. For more information about this flaw, refer to: https://access.redhat.com/site/articles/904433 Red Hat would like to thank the OpenSSL project for reporting this issue. Upstream acknowledges KIKUCHI Masashi of Lepidum as the original reporter of this issue. All OpenSSL users are advised to upgrade to these updated packages, which contain a backported patch to correct this issue. For the update to take effect, all services linked to the OpenSSL library must be restarted or the system rebooted. Solution Before applying this update, make sure all previously released errata relevant to your system have been applied. This update is available via the Red Hat Network. Details on how to use the Red Hat Network to apply this update are available at https://access.redhat.com/site/articles/11258 Updated packages.

Platform:
Oracle Linux 6
Product:
openssl098e
Reference:
ELSA-2014-0626
CVE-2014-0224
CVE-2012-2110
CVE    2
CVE-2012-2110
CVE-2014-0224
CPE    69
cpe:/a:openssl:openssl098e
cpe:/a:redhat:jboss_enterprise_application_platform:5.2.0
cpe:/a:redhat:jboss_enterprise_application_platform:6.2.3
cpe:/a:redhat:jboss_enterprise_web_server:2.0.1
...

© 2013 SecPod Technologies