[Forgot Password]
Login  Register Subscribe

23631

 
 

115084

 
 

97559

 
 

909

 
 

78730

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

Multiple buffer overflows vulnerability in OpenSSL via an invalid SRP parameter

ID: oval:org.secpod.oval:def:20878Date: (C)2014-08-25   (M)2017-08-29
Class: VULNERABILITYFamily: windows




The host is installed with OpenSSL 1.0.1 before 1.0.1i and is prone to denial of service vulnerability. The flaw is present in crypto/srp/srp_lib.c in the SRP implementation in OpenSSL, which fails to properly handle an invalid SRP (1) g, (2) A, or (3) B parameter. Successful exploitation allows remote attackers to cause a denial of service.

Platform:
Microsoft Windows 2000
Microsoft Windows 7
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows Vista
Microsoft Windows XP
Microsoft Windows 8
Microsoft Windows 8.1
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2
Microsoft Windows 10
Product:
OpenSSL
Reference:
CVE-2014-3512
CVE    1
CVE-2014-3512
CPE    35
cpe:/a:openssl:openssl:1.0.1::x64
cpe:/a:openssl:openssl:1.0.1::x86
cpe:/a:openssl:openssl:::x64
cpe:/a:openssl:openssl:::x86
...

© 2013 SecPod Technologies