[Forgot Password]
Login  Register Subscribe

23631

 
 

115084

 
 

97559

 
 

909

 
 

78730

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

SUSE-SU-2016:1457-1 -- Suse cyrus-imapd

ID: oval:org.secpod.oval:def:400675Date: (C)2016-11-22   (M)2017-11-15
Class: PATCHFamily: unix




- Previous versions of cyrus-imapd would not allow its users to disable old protocols like SSLv1 and SSLv2 that are unsafe due to various known attacks like BEAST and POODLE. https://bugzilla.cyrusimap.org/show_bug.cgi?id=3867 remedies this issue by adding the configuration option "tls_versions" to the imapd.conf file. Note that users who upgrade existing installation of this package will *not* have their imapd.conf file overwritten, i.e. their IMAP server will continue to support SSLv1 and SSLv2 like before. To disable support for those protocols, it"s necessary to edit imapd.conf manually to state "tls_versions: tls1_0 tls1_1 tls1_2". New installations, however, will have an imapd.conf file that contains these settings already, i.e. newly installed IMAP servers do *not* support SSLv1 and SSLv2 unless that support is explicitly enabled by the user. - An integer overflow vulnerability in cyrus-imapd"s urlfetch range checking code was fixed. - Support for Elliptic Curve DiffieaHellman has been added to cyrus-imapd

Platform:
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12
Product:
perl-Cyrus-IMAP
Reference:
SUSE-SU-2016:1457-1
CVE-2014-3566
CVE-2015-8076
CVE-2015-8077
CVE-2015-8078
CVE    4
CVE-2015-8076
CVE-2015-8078
CVE-2015-8077
CVE-2014-3566
...
CPE    133
cpe:/o:fedoraproject:fedora:20
cpe:/o:apple:mac_os_x:10.10.1
cpe:/o:redhat:enterprise_linux:5
cpe:/o:fedoraproject:fedora:21
...

© 2013 SecPod Technologies