[Forgot Password]
Login  Register Subscribe

23631

 
 

115084

 
 

97559

 
 

909

 
 

78730

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

RHSA-2014:1652-01 -- Redhat openssl

ID: oval:org.secpod.oval:def:501427Date: (C)2014-10-27   (M)2017-11-16
Class: PATCHFamily: unix




OpenSSL is a toolkit that implements the Secure Sockets Layer , Transport Layer Security , and Datagram Transport Layer Security protocols, as well as a full-strength, general purpose cryptography library. This update adds support for the TLS Fallback Signaling Cipher Suite Value , which can be used to prevent protocol downgrade attacks against applications which re-connect using a lower SSL/TLS protocol version when the initial connection indicating the highest supported protocol version fails. This can prevent a forceful downgrade of the communication to SSL 3.0. The SSL 3.0 protocol was found to be vulnerable to the padding oracle attack when using block cipher suites in cipher block chaining mode. This issue is identified as CVE-2014-3566, and also known under the alias POODLE. This SSL 3.0 protocol flaw will not be addressed in a future update; it is recommended that users configure their applications to require at least TLS protocol version 1.0 for secure communication. For additional information about this flaw, see the Knowledgebase article at https://access.redhat.com/articles/1232123 A memory leak flaw was found in the way OpenSSL parsed the DTLS Secure Real-time Transport Protocol extension data. A remote attacker could send multiple specially crafted handshake messages to exhaust all available memory of an SSL/TLS or DTLS server. A memory leak flaw was found in the way an OpenSSL handled failed session ticket integrity checks. A remote attacker could exhaust all available memory of an SSL/TLS or DTLS server by sending a large number of invalid session tickets to that server. All OpenSSL users are advised to upgrade to these updated packages, which contain backported patches to mitigate the CVE-2014-3566 issue and correct the CVE-2014-3513 and CVE-2014-3567 issues. For the update to take effect, all services linked to the OpenSSL library must be restarted or the system rebooted.

Platform:
Red Hat Enterprise Linux 7
Red Hat Enterprise Linux 6
Product:
openssl
Reference:
RHSA-2014:1652-01
CVE-2014-3513
CVE-2014-3567
CVE-2014-3566
CVE    3
CVE-2014-3513
CVE-2014-3566
CVE-2014-3567
CPE    136
cpe:/a:openssl:openssl
cpe:/o:redhat:enterprise_linux:7
cpe:/o:fedoraproject:fedora:20
cpe:/o:apple:mac_os_x:10.10.1
...

© 2013 SecPod Technologies