[Forgot Password]
Login  Register Subscribe

23631

 
 

115083

 
 

97389

 
 

909

 
 

78730

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

DSA-2390-1 openssl -- several

ID: oval:org.secpod.oval:def:600700Date: (C)2012-03-13   (M)2017-08-29
Class: PATCHFamily: unix




Several vulnerabilities were discovered in OpenSSL, an implementation of TLS and related protocols. The Common Vulnerabilities and Exposures project identifies the following vulnerabilities: CVE-2011-4108 The DTLS implementation performs a MAC check only if certain padding is valid, which makes it easier for remote attackers to recover plaintext via a padding oracle attack. CVE-2011-4109 A double free vulnerability when X509_V_FLAG_POLICY_CHECK is enabled, allows remote attackers to cause applications crashes and potentially allow execution of arbitrary code by triggering failure of a policy check. CVE-2011-4354 On 32-bit systems, the operations on NIST elliptic curves P-256 and P-384 are not correctly implemented, potentially leaking the private ECC key of a TLS server. CVE-2011-4576 The SSL 3.0 implementation does not properly initialize data structures for block cipher padding, which might allow remote attackers to obtain sensitive information by decrypting the padding data sent by an SSL peer. CVE-2011-4619 The Server Gated Cryptography implementation in OpenSSL does not properly handle handshake restarts, unnecessarily simplifying CPU exhaustion attacks.

Platform:
Debian 5.0
Debian 6.0
Product:
openssl
Reference:
DSA-2390-1
CVE-2011-4108
CVE-2011-4109
CVE-2011-4354
CVE-2011-4576
CVE-2011-4619
CVE    5
CVE-2011-4354
CVE-2011-4619
CVE-2011-4576
CVE-2011-4108
...
CPE    66
cpe:/o:debian:debian_linux:5.0
cpe:/a:openssl:openssl
cpe:/o:debian:debian_linux:6.0
cpe:/a:openssl:openssl:1.0.0b
...

© 2013 SecPod Technologies