[Forgot Password]
Login  Register Subscribe

23631

 
 

127000

 
 

102010

 
 

909

 
 

81341

 
 

133

 
 
Paid content will be excluded from the download.

Filter
Matches : 11084 Download | Alert*

The host is installed with Python before 2.5.6c1, 2.6.x before 2.6.7 rc2, and 2.7.x before 2.7.2 and is prone to cross site scripting vulnerability. The flaw is present in the list_directory function in Lib/SimpleHTTPServer.py in SimpleHTTPServer, which does not place a charset parameter in the Content-Type HTTP header. Successful exploitation makes it easier for remote attackers to conduct cross- ...

The host is installed with Python 2.5 and is prone to buffer overflow vulnerability. The flaw is present in the rgbimg module, which fails to properly handle a large ZSIZE value in a black-and-white (aka B/W) RGB image that triggers an invalid pointer dereference. Successful exploitation allows remote attackers to cause a denial of service (application crash).

The host is installed with Python 2.5 and is prone to integer overflow vulnerability. The flaw is present in the rgbimg module, which fails to properly handle a large image that triggers a buffer overflow. Successful exploitation allows remote attackers to have an unspecified impact.

The host is installed with Python 2.6 through 3.2 and is prone to information disclosure vulnerability. The flaw is present in the application, which creates ~/.pypirc with world-readable permissions before changing them after data has been written. Successful exploitation introduces a race condition that allows local users to obtain a username and password by reading this file.

The host is installed with Python 2.5 and is prone to multiple buffer overflow vulnerabilities. The flaws are present in the rgbimg module, which fails to properly handle an image file containing crafted data that triggers improper processing within the (1) longimagedata or (2) expandrow function. Successful exploitation allow remote attackers to have an unspecified impact.

The host is installed with Python 2.6, 2.7, 3.1, and 3.2 and is prone to multiple integer overflow vulnerabilities. The flaws are present in the in audioop.c in the audioop module, which fails to properly handle large fragment, as demonstrated by a call to audioop.lin2lin with a long string in the first argument, leading to a buffer overflow. Successful exploitation allow context-dependent attacke ...

The host is installed with Python 2.5, 2.6, and 3.0 and is prone to unspecified vulnerability. The flaw is present in is_cgi method in CGIHTTPServer.py in the CGIHTTPServer module, which fails to properly handle an HTTP GET request that lacks a / (slash) character at the beginning of the URI. Successful exploitation allows remote attackers to read script source code via an HTTP GET request.

The host is installed with Python 2.7 and 3.2 and is prone to denial of service vulnerability. The flaw is present in the application, which fails to properly handle crafted arguments, as demonstrated by a call to audioop.reverse with a one-byte string. Successful exploitation allows context-dependent attackers to cause a denial of service (memory corruption and application crash).

The host is installed with Python Python 3.2.x or 3.3.x and is prone to an algorithmic complexity vulnerability. A flaw is present in the application, which fails to handle multiple wildcard characters. Successful exploitation could allow remote attackers to crash the service.

The host is installed with Python 3.1 through 3.3 and is prone to a memory corruption vulnerability. A flaw is present in the application, which fails to handle unspecified vectors. Successful exploitation could allow remote attackers to obtain sensitive information or crash the service.


Pages:      Start    1043    1044    1045    1046    1047    1048    1049    1050    1051    1052    1053    1054    1055    1056    ..   1108

© 2013 SecPod Technologies