[Forgot Password]
Login  Register Subscribe

23631

 
 

126173

 
 

98218

 
 

909

 
 

79224

 
 

109

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML

CVE-2017-0898

Date: (C)2017-09-19   (M)2017-12-04 


Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

CVSS Score: 6.4Access Vector: NETWORK
Exploit Score: 10.0Access Complexity: LOW
Impact Score: 4.9Authentication: NONE
 Confidentiality: PARTIAL
 Integrity: NONE
 Availability: PARTIAL





Reference:
BID-100862
SECTRACK-1039363
DSA-4031
GLSA-201710-18
https://github.com/mruby/mruby/issues/3722
https://hackerone.com/reports/212241
https://www.ruby-lang.org/en/news/2017/09/14/sprintf-buffer-underrun-cve-2017-0898/

CPE    1
cpe:/a:ruby-lang:ruby:2.2.0
CWE    1
CWE-134
OVAL    4
oval:org.secpod.oval:def:1600799
oval:org.secpod.oval:def:703838
oval:org.secpod.oval:def:1600779
oval:org.secpod.oval:def:603168
...

© 2013 SecPod Technologies