[Forgot Password]
Login  Register Subscribe

24003

 
 

131573

 
 

108530

 
 

909

 
 

85343

 
 

134

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML view JSON

CVE-2017-12426Date: (C)2017-08-17   (M)2018-02-19


GitLab Community Edition (CE) and Enterprise Edition (EE) before 8.17.8, 9.0.x before 9.0.13, 9.1.x before 9.1.10, 9.2.x before 9.2.10, 9.3.x before 9.3.10, and 9.4.x before 9.4.4 might allow remote attackers to execute arbitrary code via a crafted SSH URL in a project import.

CVSS Score and Metrics +CVSS Score and Metrics -

CVSS V3 Severity:CVSS V2 Severity:
CVSS Score : 8.8CVSS Score : 6.8
Exploit Score: 2.8Exploit Score: 8.6
Impact Score: 5.9Impact Score: 6.4
 
CVSS V3 Metrics:CVSS V2 Metrics:
Attack Vector: NETWORKAccess Vector: NETWORK
Attack Complexity: LOWAccess Complexity: MEDIUM
Privileges Required: NONEAuthentication: NONE
User Interaction: REQUIREDConfidentiality: PARTIAL
Scope: UNCHANGEDIntegrity: PARTIAL
Confidentiality: HIGHAvailability: PARTIAL
Integrity: HIGH 
Availability: HIGH 
  
Reference:
https://www.mail-archive.com/linux-kernel@vger.kernel.org/msg1466490.html
https://about.gitlab.com/2017/08/10/gitlab-9-dot-4-dot-4-released/

CPE    35
cpe:/a:gitlab:gitlab:9.2.2::~~enterprise~~~
cpe:/a:gitlab:gitlab:9.1.7::~~enterprise~~~
cpe:/a:gitlab:gitlab:9.0.1::~~enterprise~~~
cpe:/a:gitlab:gitlab:9.1.5::~~enterprise~~~
...
CWE    1
CWE-20

© SecPod Technologies