[Forgot Password]
Login  Register Subscribe

24002

 
 

127027

 
 

102010

 
 

909

 
 

81374

 
 

133

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML view JSON

CVE-2017-16352Date: (C)2017-11-02   (M)2018-02-19


GraphicsMagick 1.3.26 is vulnerable to a heap-based buffer overflow vulnerability found in the "Display visual image directory" feature of the DescribeImage() function of the magick/describe.c file. One possible way to trigger the vulnerability is to run the identify command on a specially crafted MIFF format file with the verbose flag.

CVSS V3 Severity:CVSS V2 Severity:
CVSS Score  : 8.8CVSS Score  : 6.8
Exploit Score: 2.8Exploit Score: 8.6
Impact Score : 5.9Impact Score : 6.4
 
CVSS V3 Metrics:CVSS V2 Metrics:
Attack Vector: NETWORKAccess Vector: NETWORK
Attack Complexity: LOWAccess Complexity: MEDIUM
Privileges Required: NONEAuthentication: NONE
User Interaction: REQUIREDConfidentiality: PARTIAL
Scope: UNCHANGEDIntegrity: PARTIAL
Confidentiality: HIGHAvailability: PARTIAL
Integrity: HIGH 
Availability: HIGH 
  





Reference:
BID-101658
EXPLOIT-DB-43111
https://lists.debian.org/debian-lts-announce/2017/11/msg00002.html
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/snapshots/ChangeLog.txt
http://hg.graphicsmagick.org/hg/GraphicsMagick?cmd=changeset;node=7292230dd185
https://blogs.securiteam.com/index.php/archives/3494

CPE    1
cpe:/a:graphicsmagick:graphicsmagick:1.3.26
CWE    1
CWE-119

© 2013 SecPod Technologies