[Forgot Password]
Login  Register Subscribe

23631

 
 

125159

 
 

98250

 
 

909

 
 

79281

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

DSA-1745 lcms -- several vulnerabilities

ID: oval:org.mitre.oval:def:7412Date: (C)2009-12-15   (M)2017-11-27
Class: PATCHFamily: unix




Several security issues have been discovered in lcms, a color management library. The Common Vulnerabilities and Exposures project identifies the following problems: Chris Evans discovered that lcms is affected by a memory leak, which could result in a denial of service via specially crafted image files. Chris Evans discovered that lcms is prone to several integer overflows via specially crafted image files, which could lead to the execution of arbitrary code. Chris Evans discovered the lack of upper-bounds check on sizes leading to a buffer overflow, which could be used to execute arbitrary code.

Platform:
Debian 5.0
Debian 4.0
Product:
lcms
Reference:
DSA-1745
CVE-2009-0581
CVE-2009-0723
CVE-2009-0733
CVE    3
CVE-2009-0581
CVE-2009-0723
CVE-2009-0733
CPE    2
cpe:/o:debian:debian_linux:5.x
cpe:/o:debian:debian_linux:4.x

© 2013 SecPod Technologies