[Forgot Password]
Login  Register Subscribe

23631

 
 

122183

 
 

98060

 
 

909

 
 

79198

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

CESA-2009:1484 -- centos 4 i386 postgresql

ID: oval:org.secpod.oval:def:202749Date: (C)2013-05-08   (M)2017-12-06
Class: PATCHFamily: unix




PostgreSQL is an advanced object-relational database management system . It was discovered that the upstream patch for CVE-2007-6600 included in the Red Hat Security Advisory RHSA-2008:0038 did not include protection against misuse of the RESET ROLE and RESET SESSION AUTHORIZATION commands. An authenticated user could use this flaw to install malicious code that would later execute with superuser privileges. A flaw was found in the way PostgreSQL handled encoding conversion. A remote, authenticated user could trigger an encoding conversion failure, possibly leading to a temporary denial of service. Note: To exploit this issue, a locale and client encoding for which specific messages fail to translate must be selected . Note: For Red Hat Enterprise Linux 4, this update upgrades PostgreSQL to version 7.4.26. For Red Hat Enterprise Linux 5, this update upgrades PostgreSQL to version 8.1.18. If the postgresql service is running, it will be automatically restarted after installing this update.

Platform:
CentOS 4
Product:
postgresql
Reference:
CESA-2009:1484
CVE-2009-0922
CVE-2009-3230
CVE-2007-6600
CVE    3
CVE-2007-6600
CVE-2009-3230
CVE-2009-0922
CPE    88
cpe:/a:postgresql:postgresql:7.4.10
cpe:/a:postgresql:postgresql:7.4.9
cpe:/a:postgresql:postgresql:7.4.11
cpe:/a:postgresql:postgresql:7.4.8
...

© 2013 SecPod Technologies