[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

Information disclosure vulnerability curl_easy_duphandle function in curl - CVE-2014-3707

Deprecated
ID: oval:org.secpod.oval:def:21804Date: (C)2014-12-01   (M)2017-04-07
Class: VULNERABILITYFamily: unix




The host is installed with curl 7.17.1 through 7.38.0 and is prone to an information disclosure vulnerability. A flaw is present in the application, which does not properly copy HTTP POST data for an easy handle, which triggers an out-of-bounds read. Successful exploitation allows remote web servers to read sensitive memory information.

Platform:
Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 7
Product:
curl
Reference:
CVE-2014-3707
CVE    1
CVE-2014-3707
CPE    3
cpe:/a:haxx:curl
cpe:/o:redhat:enterprise_linux:7
cpe:/o:redhat:enterprise_linux:6

© 2013 SecPod Technologies