[Forgot Password]
Login  Register Subscribe

23631

 
 

122183

 
 

98060

 
 

909

 
 

79198

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

Denial of service vulnerability in pack.c in Ruby - CVE-2014-4975

ID: oval:org.secpod.oval:def:21814Date: (C)2014-12-01   (M)2017-08-29
Class: VULNERABILITYFamily: unix




The host is installed Ruby 1.9.3 and earlier or 2.x through 2.1.2 and is prone to a denial of service vulnerability. A flaw is present in the application, which fails to properly handle vectors that trigger a stack-based buffer overflow. Successful exploitation allows context-dependent attackers to cause a denial of service.

Platform:
Red Hat Enterprise Linux 7
Product:
ruby
Reference:
CVE-2014-4975
CVE    1
CVE-2014-4975
CPE    24
cpe:/a:ruby:ruby
cpe:/a:ruby-lang:ruby:2.0.0
cpe:/a:ruby-lang:ruby:2.1.1
cpe:/a:ruby-lang:ruby:2.1:-
...

© 2013 SecPod Technologies