[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96174

 
 

909

 
 

78077

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

Denial of service vulnerability in PostgreSQL by triggering a failure error message to a client-specified encoding

ID: oval:org.secpod.oval:def:33759Date: (C)2016-04-04   (M)2017-10-04
Class: VULNERABILITYFamily: windows




The host is installed with PostgreSQL 8.3.6, 8.2.12, 8.1.16, 8.0.20 or 7.4.24 and is prone to a denial of service vulnerability. A flaw is present in the application, which fails to properly handle localized error message to a client-specified encoding, as demonstrated using mismatched encoding conversion requests. Successful exploitation allows remote authenticated users to cause a denial of service (stack consumption and crash).

Platform:
Microsoft Windows 7
Microsoft Windows Server 2008
Microsoft Windows Vista
Microsoft Windows XP
Microsoft Windows 8
Microsoft Windows Server 2003
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2
Microsoft Windows 8.1
Microsoft Windows 10
Product:
PostgreSQL
Reference:
CVE-2009-0922
CVE    1
CVE-2009-0922
CPE    6
cpe:/a:postgresql:postgresql:::x86
cpe:/a:postgresql:postgresql:8.0.20
cpe:/a:postgresql:postgresql:8.2.12
cpe:/a:postgresql:postgresql:8.1.16
...

© 2013 SecPod Technologies