[Forgot Password]
Login  Register Subscribe

23631

 
 

126941

 
 

98250

 
 

909

 
 

79281

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

DSA-1780-1 libdbd-pg-perl -- several

ID: oval:org.secpod.oval:def:600297Date: (C)2011-05-13   (M)2017-11-27
Class: PATCHFamily: unix




Two vulnerabilities have been discovered in libdbd-pg-perl, the DBI driver module for PostgreSQL database access . CVE-2009-0663 A heap-based buffer overflow may allow attackers to execute arbitrary code through applications which read rows from the database using the pg_getline and getline functions. CVE-2009-1341 A memory leak in the routine which unquotes BYTEA values returned from the database allows attackers to cause a denial of service. For the old stable distribution , these problems have been fixed in version 1.49-2+etch1. For the stable distribution and the unstable distribution , these problems have been fixed in version 2.1.3-1 before the release of lenny. We recommend that you upgrade your libdbd-pg-perl package.

Platform:
Debian 4.0
Product:
libdbd-pg-perl
Reference:
DSA-1780-1
CVE-2009-0663
CVE-2009-1341
CVE    2
CVE-2009-1341
CVE-2009-0663
CPE    1
cpe:/o:debian:debian_linux:4.x

© 2013 SecPod Technologies