[Forgot Password]
Login  Register Subscribe

23631

 
 

126951

 
 

99602

 
 

909

 
 

80198

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

DSA-1866-1 kdegraphics -- several vulnerabilities

ID: oval:org.secpod.oval:def:600359Date: (C)2011-05-13   (M)2017-11-27
Class: PATCHFamily: unix




Two security issues have been discovered in kdegraphics, the graphics apps from the official KDE release. The Common Vulnerabilities and Exposures project identifies the following problems: CVE-2009-0945 It was discovered that the KSVG animation element implementation suffers from a null pointer dereference flaw, which could lead to the execution of arbitrary code. CVE-2009-1709 It was discovered that the KSVG animation element implementation is prone to a use-after-free flaw, which could lead to the execution of arbitrary code. For the stable distribution , these problems have been fixed in version 4:3.5.9-3+lenny2. For the oldstable distribution , these problems have been fixed in version 4:3.5.5-3etch4. For the testing distribution and the unstable distribution , these problems have been fixed in version 4:4.0. We recommend that you upgrade your kdegraphics packages.

Platform:
Debian 5.0
Debian 4.0
Product:
kdegraphics
Reference:
DSA-1866-1
CVE-2009-0945
CVE-2009-1709
CVE    2
CVE-2009-1709
CVE-2009-0945
CPE    2
cpe:/o:debian:debian_linux:5.x
cpe:/o:debian:debian_linux:4.x

© 2013 SecPod Technologies