[Forgot Password]
Login  Register Subscribe

24128

 
 

131573

 
 

110139

 
 

909

 
 

85964

 
 

136

Paid content will be excluded from the download.


Download | Alert*
OVAL

DSA-1816-1 apache2 -- insufficient security check

ID: oval:org.secpod.oval:def:600403Date: (C)2011-05-13   (M)2018-03-27
Class: PATCHFamily: unix




It was discovered that the Apache web server did not properly handle the "Options=" parameter to the AllowOverride directive: In the stable distribution , local users could enable script execution in Server Side Includes even in configurations where the AllowOverride directive contained only Options=IncludesNoEXEC. In the oldstable distribution , local users could enable script execution in Server Side Includes and CGI script execution in configurations where the AllowOverride directive contained any "Options=" value. For the stable distribution , this problem has been fixed in version 2.2.9-10+lenny3. The oldstable distribution , this problem has been fixed in version 2.2.3-4+etch8. For the testing distribution and the unstable distribution , this problem will be fixed in version 2.2.11-6. This advisory also provides updated apache2-mpm-itk packages which have been recompiled against the new apache2 packages . We recommend that you upgrade your apache2 packages.

Platform:
Debian 5.0
Debian 4.0
Product:
apache2
Reference:
DSA-1816-1
CVE-2009-1195
CVE    1
CVE-2009-1195
CPE    2
cpe:/o:debian:debian_linux:4.x
cpe:/o:debian:debian_linux:5.x

© SecPod Technologies