[Forgot Password]
Login  Register Subscribe

24003

 
 

131425

 
 

103942

 
 

909

 
 

84057

 
 

133

Paid content will be excluded from the download.


Download | Alert*
OVAL

DSA-1868-1 kde4libs -- several vulnerabilities

ID: oval:org.secpod.oval:def:600412Date: (C)2011-05-13   (M)2017-11-27
Class: PATCHFamily: unix




Several security issues have been discovered in kde4libs, core libraries for all KDE 4 applications. The Common Vulnerabilities and Exposures project identifies the following problems: CVE-2009-1690 It was discovered that there is a use-after-free flaw in handling certain DOM event handlers. This could lead to the execution of arbitrary code, when visiting a malicious website. CVE-2009-1698 It was discovered that there could be an uninitialised pointer when handling a Cascading Style Sheets attr function call. This could lead to the execution of arbitrary code, when visiting a malicious website. CVE-2009-1687 It was discovered that the JavaScript garbage collector does not handle allocation failures properly, which could lead to the execution of arbitrary code when visiting a malicious website. For the stable distribution , these problems have been fixed in version 4:4.1.0-3+lenny1. The oldstable distribution does not contain kde4libs. For the testing distribution , these problems will be fixed soon. For the unstable distribution , these problems have been fixed in version 4:4.3.0-1. We recommend that you upgrade your kde4libs packages.

Platform:
Debian 5.0
Product:
kde4libs
Reference:
DSA-1868-1
CVE-2009-1690
CVE-2009-1698
CVE-2009-1687
CVE    3
CVE-2009-1687
CVE-2009-1698
CVE-2009-1690
CPE    1
cpe:/o:debian:debian_linux:5.x

© 2013 SecPod Technologies