[Forgot Password]
Login  Register Subscribe

23631

 
 

126941

 
 

98250

 
 

909

 
 

79281

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

DSA-1826-1 eggdrop -- several

ID: oval:org.secpod.oval:def:600458Date: (C)2011-05-13   (M)2017-11-27
Class: PATCHFamily: unix




Several vulnerabilities have been discovered in eggdrop, an advanced IRC robot. The Common Vulnerabilities and Exposures project identifies the following problems: CVE-2007-2807 It was discovered that eggdrop is vulnerable to a buffer overflow, which could result in a remote user executing arbitrary code. The previous DSA did not fix the issue correctly. CVE-2009-1789 It was discovered that eggdrop is vulnerable to a denial of service attack, that allows remote attackers to cause a crash via a crafted PRIVMSG. For the stable distribution , these problems have been fixed in version 1.6.19-1.1+lenny1. For the old stable distribution , these problems have been fixed in version 1.6.18-1etch2. For the unstable distribution , this problem has been fixed in version 1.6.19-1.2 We recommend that you upgrade your eggdrop package.

Platform:
Debian 5.0
Debian 4.0
Product:
eggdrop
Reference:
DSA-1826-1
CVE-2007-2807
CVE-2009-1789
CVE    2
CVE-2007-2807
CVE-2009-1789
CPE    2
cpe:/o:debian:debian_linux:5.x
cpe:/o:debian:debian_linux:4.x

© 2013 SecPod Technologies