[Forgot Password]
Login  Register Subscribe

23631

 
 

115038

 
 

96078

 
 

909

 
 

78009

 
 

109

Paid content will be excluded from the download.


Download | Alert*
OVAL

USN-815-1 -- libxml2 vulnerabilities

ID: oval:org.secpod.oval:def:700434Date: (C)2011-05-13   (M)2017-10-04
Class: PATCHFamily: unix




It was discovered that libxml2 did not correctly handle root XML document element DTD definitions. If a user were tricked into processing a specially crafted XML document, a remote attacker could cause the application linked against libxml2 to crash, leading to a denial of service. It was discovered that libxml2 did not correctly parse Notation and Enumeration attribute types. If a user were tricked into processing a specially crafted XML document, a remote attacker could cause the application linked against libxml2 to crash, leading to a denial of service. USN-644-1 fixed a vulnerability in libxml2. This advisory provides the corresponding update for Ubuntu 9.04. Original advisory details: It was discovered that libxml2 did not correctly handle long entity names. If a user were tricked into processing a specially crafted XML document, a remote attacker could execute arbitrary code with user privileges or cause the application linked against libxml2 to crash, leading to a denial of service

Platform:
Ubuntu 8.04
Ubuntu 9.04
Ubuntu 6.06
Ubuntu 8.10
Product:
libxml2
Reference:
USN-815-1
CVE-2008-3529
CVE-2009-2414
CVE-2009-2416
CVE    3
CVE-2009-2414
CVE-2009-2416
CVE-2008-3529
CPE    6
cpe:/o:ubuntu:ubuntu_linux:8.04
cpe:/a:xmlsoft:libxml2:2.6.26
cpe:/a:xmlsoft:libxml2:2.6.32
cpe:/a:xmlsoft:libxml2:2.6.16
...

© 2013 SecPod Technologies