[Forgot Password]
Login  Register Subscribe

25354

 
 

132804

 
 

134729

 
 

909

 
 

109403

 
 

153

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML view JSON

CVE-2014-2745Date: (C)2014-04-11   (M)2019-06-12


Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.

CVSS Score and Metrics +CVSS Score and Metrics -

CVSS V2 Severity:
CVSS Score : 7.8
Exploit Score: 10.0
Impact Score: 6.9
 
CVSS V2 Metrics:
Access Vector: NETWORK
Access Complexity: LOW
Authentication: NONE
Confidentiality: NONE
Integrity: NONE
Availability: COMPLETE
  
Reference:
SECUNIA-57710
DSA-2895
http://openwall.com/lists/oss-security/2014/04/07/7
http://openwall.com/lists/oss-security/2014/04/09/1
http://blog.prosody.im/prosody-0-9-4-released/
http://hg.prosody.im/0.9/rev/1107d66d2ab2
http://hg.prosody.im/0.9/rev/a97591d2e1ad
http://xmpp.org/resources/security-notices/uncontrolled-resource-consumption-with-highly-compressed-xmpp-stanzas/

CPE    20
cpe:/a:prosody:prosody:0.1.0
cpe:/a:prosody:prosody:0.6.2
cpe:/a:prosody:prosody:0.8.0
cpe:/a:prosody:prosody:0.8.1
...
CWE    1
CWE-264
OVAL    2
oval:org.secpod.oval:def:601267
oval:org.secpod.oval:def:106926

© SecPod Technologies