[Forgot Password]
Login  Register Subscribe

24547

 
 

132763

 
 

123799

 
 

909

 
 

102660

 
 

150

Paid content will be excluded from the download.


Download | Alert*
CVE
view XML view JSON

CVE-2016-9941Date: (C)2017-01-02   (M)2018-03-28


Heap-based buffer overflow in rfbproto.c in LibVNCClient in LibVNCServer before 0.9.11 allows remote servers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted FramebufferUpdate message containing a subrectangle outside of the client drawing area.

CVSS Score and Metrics +CVSS Score and Metrics -

CVSS V3 Severity:CVSS V2 Severity:
CVSS Score : 9.8CVSS Score : 7.5
Exploit Score: 3.9Exploit Score: 10.0
Impact Score: 5.9Impact Score: 6.4
 
CVSS V3 Metrics:CVSS V2 Metrics:
Attack Vector: NETWORKAccess Vector: NETWORK
Attack Complexity: LOWAccess Complexity: LOW
Privileges Required: NONEAuthentication: NONE
User Interaction: NONEConfidentiality: PARTIAL
Scope: UNCHANGEDIntegrity: PARTIAL
Confidentiality: HIGHAvailability: PARTIAL
Integrity: HIGH 
Availability: HIGH 
  
Reference:
BID-95170
DSA-3753
GLSA-201702-24
https://github.com/LibVNC/libvncserver/pull/137
https://github.com/LibVNC/libvncserver/releases/tag/LibVNCServer-0.9.11

CPE    1
cpe:/a:libvncserver_project:libvncserver:0.9.10
CWE    1
CWE-119
OVAL    6
oval:org.secpod.oval:def:1800131
oval:org.secpod.oval:def:703425
oval:org.secpod.oval:def:112422
oval:org.secpod.oval:def:112409
...

© SecPod Technologies