[Forgot Password]
Login  Register Subscribe

25354

 
 

132804

 
 

134729

 
 

909

 
 

109403

 
 

153

Paid content will be excluded from the download.


Download | Alert*
OVAL

Cross-site scripting vulnerability in Jenkins - CVE-2019-1003004 (MAC OS X)

ID: oval:org.secpod.oval:def:56000Date: (C)2019-07-09   (M)2019-11-16
Class: VULNERABILITYFamily: macos




The host is installed with Jenkins LTS through 2.150.1 or Jenkins rolling release through 2.158 and is prone to an improper authorization vulnerability. A flaw is present in the application, which fails to properly handle an issue in core/src/main/java/hudson/security/AuthenticationProcessingFilter2.java. Successful exploitation could allow attackers to extend the duration of active http sessions indefinitely even though the user account may have been deleted in the mean time.

Platform:
Apple Mac OS X 10.15
Apple Mac OS X 10.8
Apple Mac OS X 10.9
Apple Mac OS X 10.10
Apple Mac OS X 10.11
Apple Mac OS X 10.12
Apple Mac OS X 10.13
Apple Mac OS X 10.14
Product:
Jenkins LTS
Jenkins rolling release
Reference:
CVE-2019-1003004
CVE    1
CVE-2019-1003004

© SecPod Technologies