[Forgot Password]
Login  Register Subscribe

24547

 
 

132804

 
 

129935

 
 

909

 
 

106980

 
 

152

Paid content will be excluded from the download.


Download | Alert*
OVAL

DSA-4203-1 vlc -- vlc

ID: oval:org.secpod.oval:def:603401Date: (C)2018-05-18   (M)2019-03-08
Class: PATCHFamily: unix




Hans Jerry Illikainen discovered a type conversion vulnerability in the MP4 demuxer of the VLC media player, which could result in the execution of arbitrary code if a malformed media file is played. This update upgrades VLC in stretch to the new 3.x release series . In addition two packages needed to be rebuild to ensure compatibility with VLC 3; phonon-backend-vlc and goldencheetah . VLC in jessie cannot be migrated to version 3 due to incompatible library changes with reverse dependencies and is thus now declared end-of-life for jessie. We recommend to upgrade to stretch or pick a different media player if that"s not an option.

Platform:
Debian 9.x
Product:
vlc
Reference:
DSA-4203-1
CVE-2017-17670
CVE    1
CVE-2017-17670
CPE    2
cpe:/o:debian:debian_linux:9.x
cpe:/a:videolan:vlc

© SecPod Technologies